using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[A-Z0-9_]+)(\=)(.*\n(?=[A-Z])|.*$)";
string input = @"K=one
K=val2
KEY3=val3
KEY4=val4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}