re = /(^[A-Z0-9_]+)(\=)(.*\n(?=[A-Z])|.*$)/m
str = 'K=one
K=val2
KEY3=val3
KEY4=val4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end