using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<u>(.+?)</u>";
string substitution = @"**\1**";
string input = @"<u>test</u>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}