use strict;
my $str = '<u>test</u>';
my $regex = qr/<u>(.+?)</u>/mp;
my $subst = '**\\1**';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";