package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{1,5}(?:[,.][0-9]{1,4})?[mk ]?`)
var str = `53.2k Followers, 11 Following, 1,396 Posts
5m Followers, 83 Following, 1.1m Posts`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}