$re = '/[0-9]{1,5}(?:[,.][0-9]{1,4})?[mk ]?/m';
$str = '53.2k Followers, 11 Following, 1,396 Posts
5m Followers, 83 Following, 1.1m Posts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);