re = /^(?=.* (?!.* ))?a ?b ?c ?d ?e ?f ?g ?h ?i ?j ?k ?$/m
str = 'a bcdefghijk
ab cdefghijk
abc defghijk
abcd efghijk
abcde fghijk
abcdef ghijk
abcdefg hijk
abcdefgh ijk
abcdefghi jk
abcdefghij k
abcdefghijk
abcdefghijk
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end