#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[a-z0-9]+://([a-z0-9.-]+))(.*\?[^,]*),"
Local $sString = "https://community.domain.tld/register?to=3662%2354564894861351532416dzda#%frfgrzfz,categorie,dateAcces,,," & @CRLF & _
"https://community.domain.tld/register?tests,categorie,dateAcces,,," & @CRLF & _
"https://community.domain.tld/register,categorie,dateAcces,,,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")