use strict;
my $str = 'https://community.domain.tld/register?to=3662%2354564894861351532416dzda#%frfgrzfz,categorie,dateAcces,,,
https://community.domain.tld/register?tests,categorie,dateAcces,,,
https://community.domain.tld/register,categorie,dateAcces,,,';
my $regex = qr/(^[a-z0-9]+://([a-z0-9.-]+))(.*\?[^,]*),/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}