$re = '/^(www\.|https?://).+$/m';
$str = 'www.test.com
http://www.test.com
https://test.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);