re = /^(www\.|https?:\/\/).+$/m
str = 'www.test.com
http://www.test.com
https://test.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end