# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\S+(?=\s+application)"
test_str = ("Conversion routine for the NYC.GENX application. - should show 'NYC.GENX'\n"
"Conversion routine for the CAP-GENY application. - should show 'CAP-GENY'\n"
"Conversion routine for the NNUAT_CHECK application. - should show 'NNUAT_CHECK'\n"
"Created on 1/1/14 11:40 AM for RUN_SCRIPT application. - should show 'NNUAT_CHECK'\n"
"Event created on 2/2/14 12:29 PM for the STOP_SERVER application. - should show 'STOP_SERVER'")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.