import Foundation
let pattern = #"\S+(?=\s+application)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Conversion routine for the NYC.GENX application. - should show 'NYC.GENX'
Conversion routine for the CAP-GENY application. - should show 'CAP-GENY'
Conversion routine for the NNUAT_CHECK application. - should show 'NNUAT_CHECK'
Created on 1/1/14 11:40 AM for RUN_SCRIPT application. - should show 'NNUAT_CHECK'
Event created on 2/2/14 12:29 PM for the STOP_SERVER application. - should show 'STOP_SERVER'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)