import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhttps?://(\\w+(?:[.-]\\w+)*\\.(?:ly|org|com|cc))\\b";
final String string = "https://www.amazon.com/Technology-Ventures-Enterprise-Thomas-Byers/dp/0073523429\n"
+ "http://www.interactivedynamicvideo.com/\n"
+ "http://www.nytimes.com/2007/11/07/movies/07stein.html?_r=0\n"
+ "http://evonomics.com/advertising-cannot-maintain-internet-heres-solution/\n"
+ "HTTPS://github.com/keppel/pinn\n"
+ "Http://phys.org/news/2015-09-scale-solar-youve.html\n"
+ "https://iot.seeed.cc\n"
+ "http://www.bfilipek.com/2016/04/custom-deleters-for-c-smart-pointers.html\n"
+ "http://beta.crowdfireapp.com/?beta=agnipath\n"
+ "https://www.valid.ly?param\n"
+ "http://css-cursor.techstream.org";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}