package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([A-Za-z]+/),(?:\d+,\d+%)+`)
var str = `Apple/,20,3%20,3%20,3%20,3,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}