$re = '/\b([A-Za-z]+/),(?:\d+,\d+%)+/m';
$str = 'Apple/,20,3%20,3%20,3%20,3,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);