re = /\<\>\s+:\s+(?<field1>\d+)/m
str = 'msg: 2018-07-07 14:30:02.226 INFO 7 --- [nio-8080-exec-6] c.f.p.a.service.CGEventRetimeService : <> : 12006'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end