#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-ZА-ЯІ1]*)([\-]*)([A-ZА-ЯІ\-]*)([\d]+)([A-ZА-ЯЁ]*)$"
Local $sString = "-Г002712" & @CRLF & _
"І-ИД063893" & @CRLF & _
"1-028174" & @CRLF & _
"І-Л014733" & @CRLF & _
"1-АП128659" & @CRLF & _
"І-СГ146931" & @CRLF & _
"1-С041292" & @CRLF & _
"1-ВЛ051152" & @CRLF & _
"1-КИ069187" & @CRLF & _
"І-255127" & @CRLF & _
"1-Л008971" & @CRLF & _
"ІІ-КГ017758" & @CRLF & _
"1-ВЛ007030" & @CRLF & _
"1-КИ008285" & @CRLF & _
"ДВІДКА" & @CRLF & _
"І-КГ030207" & @CRLF & _
"ІІІ-КГ009119" & @CRLF & _
"1-АП086136" & @CRLF & _
"1-АП076840" & @CRLF & _
"---------------------" & @CRLF & _
"1-АП048613" & @CRLF & _
"І-Л078811" & @CRLF & _
"1-АП012866" & @CRLF & _
"І-ГЮ079869" & @CRLF & _
"1-ГЮ060483" & @CRLF & _
"1-КИ089568" & @CRLF & _
"І-ГЮ079868" & @CRLF & _
"І-Л007958" & @CRLF & _
"1-АП223168" & @CRLF & _
"1-ГЮ060481" & @CRLF & _
"І-Г067471" & @CRLF & _
"І-Г002616" & @CRLF & _
"І-Л015822" & @CRLF & _
"1-АП017974" & @CRLF & _
"І-С019211" & @CRLF & _
"І-С019213" & @CRLF & _
"І-А112041" & @CRLF & _
"1-КИ160553" & @CRLF & _
"1-СГ154098" & @CRLF & _
"І-КИ122043" & @CRLF & _
"1-СГ178975" & @CRLF & _
"1-ГЮ060482" & @CRLF & _
"І-ГЮ079867" & @CRLF & _
"1-КИ276620" & @CRLF & _
"І-КИ234836" & @CRLF & _
"І-ЖС029733" & @CRLF & _
"І-БВ037801" & @CRLF & _
"1-АП006220" & @CRLF & _
"1-КИ144887" & @CRLF & _
"І-А199461" & @CRLF & _
"1-АП027501" & @CRLF & _
"І-КИ140357" & @CRLF & _
"І-КИ203458" & @CRLF & _
"І-ГЮ079745" & @CRLF & _
"І-КГ134568" & @CRLF & _
"І-ФП121614" & @CRLF & _
"1-ТП071258" & @CRLF & _
"I-389998" & @CRLF & _
"1-КИ099839" & @CRLF & _
"1-КИ091910" & @CRLF & _
"І-ГЮ079742" & @CRLF & _
"1-АП129549" & @CRLF & _
"І-ФП121553" & @CRLF & _
"І-ГЮ079744" & @CRLF & _
"1-ГЮ069409" & @CRLF & _
"І-ГЮ060318" & @CRLF & _
"1-СГ211384" & @CRLF & _
"1-БВ080562" & @CRLF & _
"1-334035" & @CRLF & _
"1-КИ091886" & @CRLF & _
"І-ЖС061642" & @CRLF & _
"1-ГЮ069411" & @CRLF & _
"І-ГЮ069284" & @CRLF & _
"І-ЖС044605" & @CRLF & _
"І-ГЮ079937" & @CRLF & _
"1-ГЮ069412" & @CRLF & _
"І-СГ019424" & @CRLF & _
"І-ГЮ079743" & @CRLF & _
"1-АП129527" & @CRLF & _
"1-А030138" & @CRLF & _
"І-ГЮ085115" & @CRLF & _
"І-ГЮ065184" & @CRLF & _
"І-106389" & @CRLF & _
"І-ГЮ071047" & @CRLF & _
"1-ГЮ069417" & @CRLF & _
"1-ВЛ153623" & @CRLF & _
"1-ВЛ162954" & @CRLF & _
"І-ГЮ079820" & @CRLF & _
"І-ГЮ071044" & @CRLF & _
"1-АП062971" & @CRLF & _
"І-КГ080596" & @CRLF & _
"І-ФП013593" & @CRLF & _
"І-ГЮ079816" & @CRLF & _
"І-КГ050684" & @CRLF & _
"1-ГЮ069416" & @CRLF & _
"І-Д111974" & @CRLF & _
"І-ГЮ079818" & @CRLF & _
"1-АП135540" & @CRLF & _
"1-А044099" & @CRLF & _
"І-ГЮ079931" & @CRLF & _
"І-ГЮ079819" & @CRLF & _
"І-ГЮ079870" & @CRLF & _
"І-И046068" & @CRLF & _
"І-К076601" & @CRLF & _
"1-К017444" & @CRLF & _
"І-ГЮ060469" & @CRLF & _
"І-ГЮ079817" & @CRLF & _
"1-ГЮ069413" & @CRLF & _
"1-СГ318235" & @CRLF & _
"1-А081279" & @CRLF & _
"І-КГ080595" & @CRLF & _
"1-АП007490" & @CRLF & _
"І-К068117" & @CRLF & _
"1-СГ046160" & @CRLF & _
"І-ГЮ079936" & @CRLF & _
"І-ГЮ069285" & @CRLF & _
"І-ГЮ069288" & @CRLF & _
"І-ГЮ060467" & @CRLF & _
"І-ГЮ071046" & @CRLF & _
"І-КГ009254" & @CRLF & _
"І-ГЮ079938" & @CRLF & _
"1-ТП202738" & @CRLF & _
"1-ГЮ060485" & @CRLF & _
"І-ГЮ069286" & @CRLF & _
"І-ГЮ060470" & @CRLF & _
"1-КИ052212" & @CRLF & _
"1-БВ076190" & @CRLF & _
"І-ГЮ060466" & @CRLF & _
"І-ГЮ071045" & @CRLF & _
"ВИДАДВІДКУ" & @CRLF & _
"1-Д050757" & @CRLF & _
"І-КГ092791" & @CRLF & _
"І-КИ086717" & @CRLF & _
"І-ГЮ071048" & @CRLF & _
"І-ГЮ071041" & @CRLF & _
"СВ-ВВИДА" & @CRLF & _
"І-ГЮ069353" & @CRLF & _
"1-ГЮ005041" & @CRLF & _
"І-Г119501" & @CRLF & _
"І-ГЮ060302" & @CRLF & _
"1-АП114999" & @CRLF & _
"1-ГЮ056591" & @CRLF & _
"І-С040269" & @CRLF & _
"1-ГЮ070977" & @CRLF & _
"І-ГЮ060454" & @CRLF & _
"І-ГЮ079772" & @CRLF & _
"1-ФП073259" & @CRLF & _
"І-ГЮ071043" & @CRLF & _
"І-С007205" & @CRLF & _
"1-ГЮ016004" & @CRLF & _
"І-ФП089676" & @CRLF & _
"І-ГЮ071088" & @CRLF & _
"І-ГЮ079773" & @CRLF & _
"1-ТП028944" & @CRLF & _
"1-ГЮ079912" & @CRLF & _
"1-ЖД152813" & @CRLF & _
"І-ГЮ069354" & @CRLF & _
"1-ТП023614" & @CRLF & _
"1-ГЮ079769" & @CRLF & _
"І-ГЮ069153" & @CRLF & _
"І-ГЮ060301" & @CRLF & _
"1-Г052053" & @CRLF & _
"1-БК070591" & @CRLF & _
"1-ГЮ070978" & @CRLF & _
"1-АП039899" & @CRLF & _
"І-ГЮ069231" & @CRLF & _
"І-АП108505" & @CRLF & _
"І-ГЮ034983" & @CRLF & _
"1-ГЮ079766" & @CRLF & _
"І-ГЮ069158" & @CRLF & _
"І-ГЮ019806" & @CRLF & _
"І-ФП093641" & @CRLF & _
"1-АП120402" & @CRLF & _
"І-ЖС003551" & @CRLF & _
"1-ГЮ079767" & @CRLF & _
"І-ГЮ069154" & @CRLF & _
"І-ГЮ060452" & @CRLF & _
"І-ГЮ069151" & @CRLF & _
"1-ГЮ070979" & @CRLF & _
"1-КИ178703" & @CRLF & _
"І-ГЮ069155" & @CRLF & _
"І-ГЮ071039" & @CRLF & _
"І-ГЮ071087" & @CRLF & _
"І-ГЮ102050" & @CRLF & _
"І-ГЮ079774" & @CRLF & _
"І-ГЮ060303" & @CRLF & _
"І-ЖС076855" & @CRLF & _
"І-ГЮ071040" & @CRLF & _
"І-ГЮ071091" & @CRLF & _
"І-ГЮ079807" & @CRLF & _
"1-КИ123065" & @CRLF & _
"І-ГЮ071090" & @CRLF & _
"1-АП023158" & @CRLF & _
"І-ГЮ069356" & @CRLF & _
"І-ГЮ071026" & @CRLF & _
"І-А112126" & @CRLF & _
"І-ГЮ071027" & @CRLF & _
"1-КИ082667" & @CRLF & _
"І-ГЮ071028" & @CRLF & _
"1-ГЮ070976" & @CRLF & _
"1-СГ259991" & @CRLF & _
"1-СГ018084" & @CRLF & _
"1-ГЮ000534" & @CRLF & _
"І-ГЮ069165" & @CRLF & _
"1-Л030767" & @CRLF & _
"1-АП009776Ё" & @CRLF & _
"1-СГ318072" & @CRLF & _
"1-ГЮ079768" & @CRLF & _
"І-ГЮ069357" & @CRLF & _
"І-КИ081218" & @CRLF & _
"І-ГЮ069229" & @CRLF & _
"1-АП084070" & @CRLF & _
"1-КИ088576" & @CRLF & _
"1-КИ160784" & @CRLF & _
"1-АП139778" & @CRLF & _
"І-ГЮ079771" & @CRLF & _
"І-ГЮ084726" & @CRLF & _
"І-ГЮ069355" & @CRLF & _
"І-ГЮ069230" & @CRLF & _
"І-ГЮ060453" & @CRLF & _
"І-Д243229" & @CRLF & _
"1-А106171" & @CRLF & _
"1-СГ288114" & @CRLF & _
"1-ГЮ079911" & @CRLF & _
"1-194798" & @CRLF & _
"І-ГБ069232" & @CRLF & _
"І-ГЮ060300" & @CRLF & _
"І-А216767" & @CRLF & _
"І-ФП121661" & @CRLF & _
"1-ГЮ079770" & @CRLF & _
"1-КИ160286" & @CRLF & _
"І-ГЮ069233" & @CRLF & _
"І-127272" & @CRLF & _
"І-ГЮ071024" & @CRLF & _
"1-ГЮ):(;!*" & @CRLF & _
"1-ВЛ061008" & @CRLF & _
"1-ВЛ087708" & @CRLF & _
"І-ГЮ060152" & @CRLF & _
"І-ФП106803" & @CRLF & _
"1-СГ222696" & @CRLF & _
"І-ГЮ071025" & @CRLF & _
"1-ВЛ137400" & @CRLF & _
"І-ФП094019" & @CRLF & _
"І-ГЮ071089" & @CRLF & _
"І-КГ018790" & @CRLF & _
"І-ГЮ056580" & @CRLF & _
"І-ГЮ056678" & @CRLF & _
"І-ГЮ056579" & @CRLF & _
"1-АП085420" & @CRLF & _
"1-А090289" & @CRLF & _
"І-ГЮ049451" & @CRLF & _
"І-ГЮ056453" & @CRLF & _
"І-ЖС048402" & @CRLF & _
"І-ГЮ056454" & @CRLF & _
"І-ГЮ065604" & @CRLF & _
"І-ГЮ056672" & @CRLF & _
"І-Г072389" & @CRLF & _
"І-ГЮ065542" & @CRLF & _
"І-ГЮ057937" & @CRLF & _
"І-ЖС008451" & @CRLF & _
"І-ГЮ065603" & @CRLF & _
"І-АП058276" & @CRLF & _
"І-АП058513" & @CRLF & _
"І-ГЮ065538" & @CRLF & _
"1-СГ333556" & @CRLF & _
"1-200293" & @CRLF & _
"1-ВЛ010179" & @CRLF & _
"1-ВЛ050583" & @CRLF & _
"ІАП036135" & @CRLF & _
"1-КИ069058" & @CRLF & _
"І-ГЮ049427" & @CRLF & _
"І-ГЮ057921" & @CRLF & _
"І-КГ228431" & @CRLF & _
"І-ГЮ049355" & @CRLF & _
"1-КИ119834" & @CRLF & _
"1-ТП121575" & @CRLF & _
"І-ГЮ057922" & @CRLF & _
"І-Л074336" & @CRLF & _
"1-СГ115852" & @CRLF & _
"1-ГЮ005018" & @CRLF & _
"1-АП086186" & @CRLF & _
"1-ГЮ049346" & @CRLF & _
"І-ГЮ049455" & @CRLF & _
"І-ГЮ057960" & @CRLF & _
"1-КИ199276" & @CRLF & _
"1-ГЮ049347" & @CRLF & _
"1-КИ127680" & @CRLF & _
"І-ГЮ056455" & @CRLF & _
"1-БК070429" & @CRLF & _
"І-ГЮ056578" & @CRLF & _
"І-СГ131185" & @CRLF & _
"І-ГЮ049315" & @CRLF & _
"І-ГЮ049452" & @CRLF & _
"І-ГЮ065601" & @CRLF & _
"І-ГЮ049454" & @CRLF & _
"І-ГЮ056674" & @CRLF & _
"І-ЖС042699" & @CRLF & _
"079380" & @CRLF & _
"1-СГ029058" & @CRLF & _
"І-ГЮ057916" & @CRLF & _
"І-ГЮ056577" & @CRLF & _
"1-СГ142897" & @CRLF & _
"1-Д246695" & @CRLF & _
"І-КГ019161" & @CRLF & _
"1-ВЛ055174" & @CRLF & _
"І-ГЮ065510" & @CRLF & _
"І-КГ086053" & @CRLF & _
"ВИДАДВІДКУПА" & @CRLF & _
"1-КИ091821" & @CRLF & _
"1-БВ126614" & @CRLF & _
"І-КГ037489" & @CRLF & _
"І-ЖД327937" & @CRLF & _
"І-КИ164491" & @CRLF & _
"І-ГЮ049429" & @CRLF & _
"І-ГЮ058998" & @CRLF & _
"СВІДЦТВВИДА" & @CRLF & _
"І-ЖС046868" & @CRLF & _
"1-Д246979" & @CRLF & _
"І-ГЮ057936" & @CRLF & _
"І-СГ204213" & @CRLF & _
"ВИДААДВІДКА" & @CRLF & _
"І-ЖС" & @CRLF & _
"281277" & @CRLF & _
"1-Д054608" & @CRLF & _
"1Д054608" & @CRLF & _
"І-ЖС-" & @CRLF & _
"І-ГЮ057917" & @CRLF & _
"1-СГ343084" & @CRLF & _
"І-ГЮ065508" & @CRLF & _
"І-ГЮ057919" & @CRLF & _
"І-ГЮ065540" & @CRLF & _
"1-ФП067440" & @CRLF & _
"1-ТП009545" & @CRLF & _
"1-КИ088488" & @CRLF & _
"І-ГЮ044602" & @CRLF & _
"І-ГЮ065543" & @CRLF & _
"І-ГЮ000465" & @CRLF & _
"1-ВЛ113896" & @CRLF & _
"І-ГЮ056669" & @CRLF & _
"І-ФП061321" & @CRLF & _
"І-ГЮ049356" & @CRLF & _
"1-ТП065154" & @CRLF & _
"І-КГ123085" & @CRLF & _
"І-ГЮ057906" & @CRLF & _
"1-Д237480" & @CRLF & _
"І-ГЮ056643" & @CRLF & _
"І-ГЮ065506" & @CRLF & _
"І-161338" & @CRLF & _
"1-ВЛ113896" & @CRLF & _
"І-ФП035224" & @CRLF & _
"І-КГ008661" & @CRLF & _
"І-ГЮ065544" & @CRLF & _
"І-172161" & @CRLF & _
"І-ФП068803" & @CRLF & _
"І-ФП068804" & @CRLF & _
"І-ГЮ044604" & @CRLF & _
"І-ГЮ065622" & @CRLF & _
"І-ФП119401" & @CRLF & _
"І-ФП130210" & @CRLF & _
"І-СГ220409" & @CRLF & _
"І-СГ261707" & @CRLF & _
"І-ГЮ049468" & @CRLF & _
"І-ГЮ044601" & @CRLF & _
"1-КГ092546" & @CRLF & _
"094824" & @CRLF & _
"І-КГ019211" & @CRLF & _
"1-ГЮ056449" & @CRLF & _
"1-ГЮ057949" & @CRLF & _
"І-ГЮ056641" & @CRLF & _
"І-ГЮ070383" & @CRLF & _
"І-ГЮ049430" & @CRLF & _
"І-КИ018489" & @CRLF & _
"І-ГЮ057864" & @CRLF & _
"І-ГЮ056670" & @CRLF & _
"І-ГЮ057910" & @CRLF & _
"1-КИ087569" & @CRLF & _
"І-ГЮ065513" & @CRLF & _
"І-ГЮ049415" & @CRLF & _
"І-ГЮ057984" & @CRLF & _
"1-ГЮ056441" & @CRLF & _
"І-ГЮ065511" & @CRLF & _
"І-СГ204242" & @CRLF & _
"І-СГ068915" & @CRLF & _
"І-Г004769" & @CRLF & _
"І-С074924" & @CRLF & _
"1-КИ099876" & @CRLF & _
"1-КИ117306" & @CRLF & _
"1-ГЮ056448" & @CRLF & _
"І-ГЮ049359" & @CRLF & _
"1-СГ061130" & @CRLF & _
"І-ФП026127" & @CRLF & _
"1-ТП015443" & @CRLF & _
"І-ГЮ049360" & @CRLF & _
"1-СГ080164" & @CRLF & _
"І-ГЮ049414" & @CRLF & _
"1-СГ343177" & @CRLF & _
"І-ГЮ049330" & @CRLF & _
"І-ГЮ065621" & @CRLF & _
"І-БК141010" & @CRLF & _
"1-ГЮ056446" & @CRLF & _
"І-ГЮ065512" & @CRLF & _
"1-ГЮ007905" & @CRLF & _
"1-КИ080324" & @CRLF & _
"1-ГЮ056445" & @CRLF & _
"І-ГЮ049470" & @CRLF & _
"І-КИ146938" & @CRLF & _
"І-ГЮ056516" & @CRLF & _
"І-ГЮ056452" & @CRLF & _
"1-ГЮ049344" & @CRLF & _
"І-СГ113157" & @CRLF & _
"І-004569" & @CRLF & _
"І-252971" & @CRLF & _
"1-ВЛ022633" & @CRLF & _
"1-КГ087722" & @CRLF & _
"1-Д139943" & @CRLF & _
"1-КИ085638" & @CRLF & _
"І-ГЮ049343" & @CRLF & _
"І-КГ030081" & @CRLF & _
"І-ГЮ044600" & @CRLF & _
"-Л037993" & @CRLF & _
"І-ГЮ056639" & @CRLF & _
"І-КГ136427" & @CRLF & _
"І-КИ234953" & @CRLF & _
"І-ГЮ057994" & @CRLF & _
"І-ГЮ057995" & @CRLF & _
"І-С105260" & @CRLF & _
"І-С064864" & @CRLF & _
"І-ГЮ057925" & @CRLF & _
"І-СГ068947" & @CRLF & _
"1-КИ120052" & @CRLF & _
"1-Д111322" & @CRLF & _
"1-К071634" & @CRLF & _
"І-Г013705" & @CRLF & _
"І-ГЮ049456" & @CRLF & _
"1-Г028963" & @CRLF & _
"1-Г0850345" & @CRLF & _
"І-ГЮ049460" & @CRLF & _
"І-ГЮ049457" & @CRLF & _
"1-К011683" & @CRLF & _
"І-ГЮ044703" & @CRLF & _
"1-Д186995" & @CRLF & _
"І-С064945" & @CRLF & _
"І-ГЮ057923" & @CRLF & _
"І-ГЮ057918" & @CRLF & _
"І-ГЮ057985" & @CRLF & _
"І-СГ274985" & @CRLF & _
"І-ГЮ049434" & @CRLF & _
"1-Л040584" & @CRLF & _
"1-ТП068259" & @CRLF & _
"1-ГЮ272062" & @CRLF & _
"І-АП114690" & @CRLF & _
"1-Д264500" & @CRLF & _
"1-Д054521" & @CRLF & _
"І-ФП068327" & @CRLF & _
"1-ГЮ049348" & @CRLF & _
"1-ФП042384" & @CRLF & _
"І-ГЮ049459" & @CRLF & _
"І-ЖС088476" & @CRLF & _
"1-ГЮ056443" & @CRLF & _
"1-Д237471" & @CRLF & _
"1-КИ194712" & @CRLF & _
"1-КИ008298" & @CRLF & _
"І-КГ037328" & @CRLF & _
"ІЖС052251" & @CRLF & _
"І-ГЮ049337" & @CRLF & _
"І-КГ080693" & @CRLF & _
"І-ЖД306604" & @CRLF & _
"І-ГЮ056684" & @CRLF & _
"1-АП186277" & @CRLF & _
"І-КИВИДА" & @CRLF & _
"І-ГЮ065553" & @CRLF & _
"І-ГЮ049340" & @CRLF & _
"І-ТП272562" & @CRLF & _
"І-ТП279021" & @CRLF & _
"1-ТП103104" & @CRLF & _
"І-ГЮ049413" & @CRLF & _
"1-Л021936" & @CRLF & _
"СВІДЦТВВИДА." & @CRLF & _
"1-АП168687" & @CRLF & _
"І-346530" & @CRLF & _
"І-ГЮ049336" & @CRLF & _
"1-Г029053" & @CRLF & _
"І-ГЮ057861" & @CRLF & _
"067125" & @CRLF & _
"І-170879" & @CRLF & _
"1-ФП073214" & @CRLF & _
"1-ФП062671" & @CRLF & _
"ІГ072493" & @CRLF & _
"І-ГЮ065551" & @CRLF & _
"І-АП114083" & @CRLF & _
"І-ГЮ057863" & @CRLF & _
"І-ЖС010611" & @CRLF & _
"І-ГЮ049462" & @CRLF & _
"1-КИ099481" & @CRLF & _
"1-Ф11039926" & @CRLF & _
"І-АП108768" & @CRLF & _
"1-ФП083031" & @CRLF & _
"1-АП015832"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")