using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-ZА-ЯІ1]*)([\-]*)([A-ZА-ЯІ\-]*)([\d]+)([A-ZА-ЯЁ]*)$";
string input = @"-Г002712
І-ИД063893
1-028174
І-Л014733
1-АП128659
І-СГ146931
1-С041292
1-ВЛ051152
1-КИ069187
І-255127
1-Л008971
ІІ-КГ017758
1-ВЛ007030
1-КИ008285
ДВІДКА
І-КГ030207
ІІІ-КГ009119
1-АП086136
1-АП076840
---------------------
1-АП048613
І-Л078811
1-АП012866
І-ГЮ079869
1-ГЮ060483
1-КИ089568
І-ГЮ079868
І-Л007958
1-АП223168
1-ГЮ060481
І-Г067471
І-Г002616
І-Л015822
1-АП017974
І-С019211
І-С019213
І-А112041
1-КИ160553
1-СГ154098
І-КИ122043
1-СГ178975
1-ГЮ060482
І-ГЮ079867
1-КИ276620
І-КИ234836
І-ЖС029733
І-БВ037801
1-АП006220
1-КИ144887
І-А199461
1-АП027501
І-КИ140357
І-КИ203458
І-ГЮ079745
І-КГ134568
І-ФП121614
1-ТП071258
I-389998
1-КИ099839
1-КИ091910
І-ГЮ079742
1-АП129549
І-ФП121553
І-ГЮ079744
1-ГЮ069409
І-ГЮ060318
1-СГ211384
1-БВ080562
1-334035
1-КИ091886
І-ЖС061642
1-ГЮ069411
І-ГЮ069284
І-ЖС044605
І-ГЮ079937
1-ГЮ069412
І-СГ019424
І-ГЮ079743
1-АП129527
1-А030138
І-ГЮ085115
І-ГЮ065184
І-106389
І-ГЮ071047
1-ГЮ069417
1-ВЛ153623
1-ВЛ162954
І-ГЮ079820
І-ГЮ071044
1-АП062971
І-КГ080596
І-ФП013593
І-ГЮ079816
І-КГ050684
1-ГЮ069416
І-Д111974
І-ГЮ079818
1-АП135540
1-А044099
І-ГЮ079931
І-ГЮ079819
І-ГЮ079870
І-И046068
І-К076601
1-К017444
І-ГЮ060469
І-ГЮ079817
1-ГЮ069413
1-СГ318235
1-А081279
І-КГ080595
1-АП007490
І-К068117
1-СГ046160
І-ГЮ079936
І-ГЮ069285
І-ГЮ069288
І-ГЮ060467
І-ГЮ071046
І-КГ009254
І-ГЮ079938
1-ТП202738
1-ГЮ060485
І-ГЮ069286
І-ГЮ060470
1-КИ052212
1-БВ076190
І-ГЮ060466
І-ГЮ071045
ВИДАДВІДКУ
1-Д050757
І-КГ092791
І-КИ086717
І-ГЮ071048
І-ГЮ071041
СВ-ВВИДА
І-ГЮ069353
1-ГЮ005041
І-Г119501
І-ГЮ060302
1-АП114999
1-ГЮ056591
І-С040269
1-ГЮ070977
І-ГЮ060454
І-ГЮ079772
1-ФП073259
І-ГЮ071043
І-С007205
1-ГЮ016004
І-ФП089676
І-ГЮ071088
І-ГЮ079773
1-ТП028944
1-ГЮ079912
1-ЖД152813
І-ГЮ069354
1-ТП023614
1-ГЮ079769
І-ГЮ069153
І-ГЮ060301
1-Г052053
1-БК070591
1-ГЮ070978
1-АП039899
І-ГЮ069231
І-АП108505
І-ГЮ034983
1-ГЮ079766
І-ГЮ069158
І-ГЮ019806
І-ФП093641
1-АП120402
І-ЖС003551
1-ГЮ079767
І-ГЮ069154
І-ГЮ060452
І-ГЮ069151
1-ГЮ070979
1-КИ178703
І-ГЮ069155
І-ГЮ071039
І-ГЮ071087
І-ГЮ102050
І-ГЮ079774
І-ГЮ060303
І-ЖС076855
І-ГЮ071040
І-ГЮ071091
І-ГЮ079807
1-КИ123065
І-ГЮ071090
1-АП023158
І-ГЮ069356
І-ГЮ071026
І-А112126
І-ГЮ071027
1-КИ082667
І-ГЮ071028
1-ГЮ070976
1-СГ259991
1-СГ018084
1-ГЮ000534
І-ГЮ069165
1-Л030767
1-АП009776Ё
1-СГ318072
1-ГЮ079768
І-ГЮ069357
І-КИ081218
І-ГЮ069229
1-АП084070
1-КИ088576
1-КИ160784
1-АП139778
І-ГЮ079771
І-ГЮ084726
І-ГЮ069355
І-ГЮ069230
І-ГЮ060453
І-Д243229
1-А106171
1-СГ288114
1-ГЮ079911
1-194798
І-ГБ069232
І-ГЮ060300
І-А216767
І-ФП121661
1-ГЮ079770
1-КИ160286
І-ГЮ069233
І-127272
І-ГЮ071024
1-ГЮ):(;!*
1-ВЛ061008
1-ВЛ087708
І-ГЮ060152
І-ФП106803
1-СГ222696
І-ГЮ071025
1-ВЛ137400
І-ФП094019
І-ГЮ071089
І-КГ018790
І-ГЮ056580
І-ГЮ056678
І-ГЮ056579
1-АП085420
1-А090289
І-ГЮ049451
І-ГЮ056453
І-ЖС048402
І-ГЮ056454
І-ГЮ065604
І-ГЮ056672
І-Г072389
І-ГЮ065542
І-ГЮ057937
І-ЖС008451
І-ГЮ065603
І-АП058276
І-АП058513
І-ГЮ065538
1-СГ333556
1-200293
1-ВЛ010179
1-ВЛ050583
ІАП036135
1-КИ069058
І-ГЮ049427
І-ГЮ057921
І-КГ228431
І-ГЮ049355
1-КИ119834
1-ТП121575
І-ГЮ057922
І-Л074336
1-СГ115852
1-ГЮ005018
1-АП086186
1-ГЮ049346
І-ГЮ049455
І-ГЮ057960
1-КИ199276
1-ГЮ049347
1-КИ127680
І-ГЮ056455
1-БК070429
І-ГЮ056578
І-СГ131185
І-ГЮ049315
І-ГЮ049452
І-ГЮ065601
І-ГЮ049454
І-ГЮ056674
І-ЖС042699
079380
1-СГ029058
І-ГЮ057916
І-ГЮ056577
1-СГ142897
1-Д246695
І-КГ019161
1-ВЛ055174
І-ГЮ065510
І-КГ086053
ВИДАДВІДКУПА
1-КИ091821
1-БВ126614
І-КГ037489
І-ЖД327937
І-КИ164491
І-ГЮ049429
І-ГЮ058998
СВІДЦТВВИДА
І-ЖС046868
1-Д246979
І-ГЮ057936
І-СГ204213
ВИДААДВІДКА
І-ЖС
281277
1-Д054608
1Д054608
І-ЖС-
І-ГЮ057917
1-СГ343084
І-ГЮ065508
І-ГЮ057919
І-ГЮ065540
1-ФП067440
1-ТП009545
1-КИ088488
І-ГЮ044602
І-ГЮ065543
І-ГЮ000465
1-ВЛ113896
І-ГЮ056669
І-ФП061321
І-ГЮ049356
1-ТП065154
І-КГ123085
І-ГЮ057906
1-Д237480
І-ГЮ056643
І-ГЮ065506
І-161338
1-ВЛ113896
І-ФП035224
І-КГ008661
І-ГЮ065544
І-172161
І-ФП068803
І-ФП068804
І-ГЮ044604
І-ГЮ065622
І-ФП119401
І-ФП130210
І-СГ220409
І-СГ261707
І-ГЮ049468
І-ГЮ044601
1-КГ092546
094824
І-КГ019211
1-ГЮ056449
1-ГЮ057949
І-ГЮ056641
І-ГЮ070383
І-ГЮ049430
І-КИ018489
І-ГЮ057864
І-ГЮ056670
І-ГЮ057910
1-КИ087569
І-ГЮ065513
І-ГЮ049415
І-ГЮ057984
1-ГЮ056441
І-ГЮ065511
І-СГ204242
І-СГ068915
І-Г004769
І-С074924
1-КИ099876
1-КИ117306
1-ГЮ056448
І-ГЮ049359
1-СГ061130
І-ФП026127
1-ТП015443
І-ГЮ049360
1-СГ080164
І-ГЮ049414
1-СГ343177
І-ГЮ049330
І-ГЮ065621
І-БК141010
1-ГЮ056446
І-ГЮ065512
1-ГЮ007905
1-КИ080324
1-ГЮ056445
І-ГЮ049470
І-КИ146938
І-ГЮ056516
І-ГЮ056452
1-ГЮ049344
І-СГ113157
І-004569
І-252971
1-ВЛ022633
1-КГ087722
1-Д139943
1-КИ085638
І-ГЮ049343
І-КГ030081
І-ГЮ044600
-Л037993
І-ГЮ056639
І-КГ136427
І-КИ234953
І-ГЮ057994
І-ГЮ057995
І-С105260
І-С064864
І-ГЮ057925
І-СГ068947
1-КИ120052
1-Д111322
1-К071634
І-Г013705
І-ГЮ049456
1-Г028963
1-Г0850345
І-ГЮ049460
І-ГЮ049457
1-К011683
І-ГЮ044703
1-Д186995
І-С064945
І-ГЮ057923
І-ГЮ057918
І-ГЮ057985
І-СГ274985
І-ГЮ049434
1-Л040584
1-ТП068259
1-ГЮ272062
І-АП114690
1-Д264500
1-Д054521
І-ФП068327
1-ГЮ049348
1-ФП042384
І-ГЮ049459
І-ЖС088476
1-ГЮ056443
1-Д237471
1-КИ194712
1-КИ008298
І-КГ037328
ІЖС052251
І-ГЮ049337
І-КГ080693
І-ЖД306604
І-ГЮ056684
1-АП186277
І-КИВИДА
І-ГЮ065553
І-ГЮ049340
І-ТП272562
І-ТП279021
1-ТП103104
І-ГЮ049413
1-Л021936
СВІДЦТВВИДА.
1-АП168687
І-346530
І-ГЮ049336
1-Г029053
І-ГЮ057861
067125
І-170879
1-ФП073214
1-ФП062671
ІГ072493
І-ГЮ065551
І-АП114083
І-ГЮ057863
І-ЖС010611
І-ГЮ049462
1-КИ099481
1-Ф11039926
І-АП108768
1-ФП083031
1-АП015832";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}