#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bRHS \d+\.?\d?x\d+\.?\d?x\d+\.?\d?(?!\.?\d?x)\b"
Local $sString = "foo RHS 100x100x10 foo " & @CRLF & _
"foo RHS 100.0x100x10 foo " & @CRLF & _
"foo RHS 100.0x100.0x10.0 foo" & @CRLF & _
"foo RHS 100x100.0x100x10 foo " & @CRLF & _
"foo RHS 10.0x100.0x10.0x10.0 foo "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")