import re
regex = re.compile(r"\bRHS \d+\.?\d?x\d+\.?\d?x\d+\.?\d?(?!\.?\d?x)\b")
test_str = ("foo RHS 100x100x10 foo \n"
"foo RHS 100.0x100x10 foo \n"
"foo RHS 100.0x100.0x10.0 foo\n"
"foo RHS 100x100.0x100x10 foo \n"
"foo RHS 10.0x100.0x10.0x10.0 foo ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")