re = /[[:alnum:]]/m
str = 'MS-05B
05B-MS
ザク MS 05B
(旧ザク)MS-05B ザクI
MS: 05B
;MS;
"MS"
\'MS\'
MS.MS,MS
[MS]
{MS}
MS -- 改行は境界扱い
(MS) -- 全角記号は境界扱い
{MS}
-- 数値は境界扱いされない
001MS999
-- 非アルファベット文字が境界扱いされる(PCRE/JS/Python/Golang)
ザクMSザク
量産MS量産'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end