package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(([\-]?[0-9]*[a-z])([\-\+][0-9]*)\)\^([0-9]+)`)
var str = `(x+1)^2
(p-1)^3
(2f+4)^6
(12t+43)^2
(12t+43)^23
(-12t+43)^2
(x+1)^0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}