using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(@(annually|yearly|monthly|weekly|daily|hourly|reboot))|(@every (\d+(ns|us|µs|ms|s|m|h))+)|(^((?!\*-)((\d+,)+\d+|([\d\*]+(\/|-)\d+)|\d+|(?<!\d)\*(?!\d)) ?){5,7})";
string input = @"# should pass:
0 0 0 1 1 * 1
0 0 0 1 1 * 1,2
0 0 0 1 1 * 1,2,3
0 0 0 1 * * 1/4
0 0 0 * * 0 1-4
0 0 0 * * * 2/4
0 0 * * * * *
* * * * *
*/5 * * * *
0 0,12 1 */2 *
0 4 8-14 * *
0 0 1,15 * 3
@weekly
5 0 * 8 *
0 22 * * 1-5
23 0-20/2 * * *
0 0,12 1 */2 *
# should not pass:
*-* * * * *
* * *-1 * *
*1 * 1 * *
1* * 1 * *
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}