import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(@(annually|yearly|monthly|weekly|daily|hourly|reboot))|(@every (\\d+(ns|us|µs|ms|s|m|h))+)|(^((?!\\*-)((\\d+,)+\\d+|([\\d\\*]+(\\/|-)\\d+)|\\d+|(?<!\\d)\\*(?!\\d)) ?){5,7})";
final String string = "# should pass:\n"
+ "0 0 0 1 1 * 1\n"
+ "0 0 0 1 1 * 1,2\n"
+ "0 0 0 1 1 * 1,2,3\n"
+ "0 0 0 1 * * 1/4\n"
+ "0 0 0 * * 0 1-4\n"
+ "0 0 0 * * * 2/4\n"
+ "0 0 * * * * *\n"
+ "* * * * *\n"
+ "*/5 * * * *\n"
+ "0 0,12 1 */2 *\n"
+ "0 4 8-14 * *\n"
+ "0 0 1,15 * 3\n"
+ "@weekly\n"
+ "5 0 * 8 *\n"
+ "0 22 * * 1-5\n"
+ "23 0-20/2 * * *\n"
+ "0 0,12 1 */2 *\n\n"
+ "# should not pass:\n"
+ "*-* * * * *\n"
+ "* * *-1 * *\n"
+ "*1 * 1 * *\n"
+ "1* * 1 * *\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}