using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https:\/\/youtu\.be\/|http:\/\/www\.youtube\.com\/watch\?v=).*$";
string input = @"http://www.youtube.com/watch?v=u8nQa1cJyX8
https://youtu.be/x3ov9USxVxY
sdfgsdg dfsgdfsgdf
https://youtu.be/u8nQa1cJyX8
sdfsfsdfs-foo-dsfsdf
foohfghdfghsdsfgh
barfghfghdfghfgh
dfghdfghdfghdfg
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}