use strict;
my $str = 'http://www.youtube.com/watch?v=u8nQa1cJyX8
https://youtu.be/x3ov9USxVxY
sdfgsdg dfsgdfsgdf
https://youtu.be/u8nQa1cJyX8
sdfsfsdfs-foo-dsfsdf
foohfghdfghsdsfgh
barfghfghdfghfgh
dfghdfghdfghdfg
';
my $regex = qr/^(https:\/\/youtu\.be\/|http:\/\/www\.youtube\.com\/watch\?v=).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}