const regex = /(?!.*two.*three|.*three.*two)^.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!.*two.*three|.*three.*two)^.*$', 'gm')
const str = `one two three four
one three two
one two
one three
four`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}