$re = '/(?!.*two.*three|.*three.*two)^.*$/m';
$str = 'one two three four
one three two
one two
one three
four';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);