$re = '/(\w+)(?:,\s*party of (\d+)|(?![^,]))/m';
$str = 'John, party of 4
william, party of 6 dislikes John, jeff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);