import re
regex = re.compile(r"(\w+)(?:,\s*party of (\d+)|(?![^,]))", flags=re.MULTILINE)
test_str = ("John, party of 4\n"
"william, party of 6 dislikes John, jeff")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")