use strict;
my $str = 'SHOULD MATCH:
https://domain.com/search=any%20url%20encoded_word-here
https://domain.com/search=any%20url%20encoded_word-here%20
https://domain.com/search=z%C5%82oty%20z%C5%82oty%20z%C5%82oty
https://domain.com/search=z%C5%82oty%20z%C5%82ota%20%C5%82ata
https://domain.com/search=any%20%20word%20%20here
https://domain.com/search=any%20word%20here&color=blue
https://domain.com/search=any-1st%20word_2nd%20here3
SHOULD NOT MATCH:
https://domain.com/search=one%20two%20three%20four
https://domain.com/search=one%20%20two%20%20three%20%20four
https://domain.com/search=one%20%20two%20three%20%20four
https://domain.com/search=one%20%20two%20%20three%20%20four
https://domain.com/search=one%20two%20three%20four&color=blue
https://domain.com/search=z%C5%82oty%20z%C5%82oty%20z%C5%82oty%20word
';
my $regex = qr/((.*?)(%20){1,}){2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}