// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((.*?)(%20){1,}){2}").unwrap();
let string = "SHOULD MATCH:
https://domain.com/search=any%20url%20encoded_word-here
https://domain.com/search=any%20url%20encoded_word-here%20
https://domain.com/search=z%C5%82oty%20z%C5%82oty%20z%C5%82oty
https://domain.com/search=z%C5%82oty%20z%C5%82ota%20%C5%82ata
https://domain.com/search=any%20%20word%20%20here
https://domain.com/search=any%20word%20here&color=blue
https://domain.com/search=any-1st%20word_2nd%20here3
SHOULD NOT MATCH:
https://domain.com/search=one%20two%20three%20four
https://domain.com/search=one%20%20two%20%20three%20%20four
https://domain.com/search=one%20%20two%20three%20%20four
https://domain.com/search=one%20%20two%20%20three%20%20four
https://domain.com/search=one%20two%20three%20four&color=blue
https://domain.com/search=z%C5%82oty%20z%C5%82oty%20z%C5%82oty%20word
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}