# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!(?:.+?%20){3}+.)(?:.+?%20){2}.+?(?:%20)?$"
test_str = ("https://domain.com/search=any%20url%20encoded_word-here\n"
"https://domain.com/search=any%20url%20encoded_word-here%20\n"
"https://domain.com/search=z%C5%82oty%20z%C5%82oty%20z%C5%82oty\n"
"https://domain.com/search=z%C5%82oty%20z%C5%82ota%20%C5%82ata\n"
"https://domain.com/search=any%20%20word%20%20here\n"
"https://domain.com/search=any%20word%20here&color=blue\n"
"https://domain.com/search=any-1st%20word_2nd%20here3\n\n"
"https://example.com/search=one%20two\n"
"https://domain.com/search=one%20two%20three%20four\n"
"https://domain.com/search=one%20%20two%20%20three%20%20four\n"
"https://domain.com/search=one%20%20two%20three%20%20four\n"
"https://domain.com/search=one%20%20two%20%20three%20%20four\n"
"https://domain.com/search=one%20two%20three%20four&color=blue\n"
"https://domain.com/search=z%C5%82oty%20z%C5%82oty%20z%C5%82oty%20word\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.