// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,2}[\.\/-]\d{1,2}[\.\/-](?:\d{4}|\d{2})\b").unwrap();
let string = "01.11.11
12/22/22
12/12/1981
1*51*12
22|1|13
12.23.192
03-02-1919
1-22-12
01-23-18
03-23-1984
01.11.18
2.2.17
02.02.18
12.1.16
12.23.1943
01-23-11
12.23.19";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}