import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:90|(?:[0-8]{0,1}[0-9]))[°\\s](?:[0-5]{0,1}[0-9])['\\s](?:[0-5]{0,1}[0-9](?:[.,]\\d{1,5})?)[\"\\s]{0,1}[NS]\\s?,?\\s?(?:180|(?:1[0-7]{1}[0-9]{1})|(?:0?[0-9]{1}[0-9]{1})|(?:[0-9]{1}))[°\\s](?:[0-5]{0,1}[0-9])['\\s](?:[0-5]{0,1}[0-9](?:[.,]\\d{1,5})?)[\"\\s]{0,1}[EW]";
final String string = "40 31 21N, 105 05 39.00W";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}