const regex = /(?:90|(?:[0-8]{0,1}[0-9]))[°\s](?:[0-5]{0,1}[0-9])['\s](?:[0-5]{0,1}[0-9](?:[.,]\d{1,5})?)["\s]{0,1}[NS]\s?,?\s?(?:180|(?:1[0-7]{1}[0-9]{1})|(?:0?[0-9]{1}[0-9]{1})|(?:[0-9]{1}))[°\s](?:[0-5]{0,1}[0-9])['\s](?:[0-5]{0,1}[0-9](?:[.,]\d{1,5})?)["\s]{0,1}[EW]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:90|(?:[0-8]{0,1}[0-9]))[°\\s](?:[0-5]{0,1}[0-9])[\'\\s](?:[0-5]{0,1}[0-9](?:[.,]\\d{1,5})?)["\\s]{0,1}[NS]\\s?,?\\s?(?:180|(?:1[0-7]{1}[0-9]{1})|(?:0?[0-9]{1}[0-9]{1})|(?:[0-9]{1}))[°\\s](?:[0-5]{0,1}[0-9])[\'\\s](?:[0-5]{0,1}[0-9](?:[.,]\\d{1,5})?)["\\s]{0,1}[EW]', 'g')
const str = `40 31 21N, 105 05 39.00W`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}