using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[а-яА-Я]+аш[а-яА-Я]+";
string input = @"Маша ела кашу, Саша любит Дашуню, это дети наши";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}