re = /[а-яА-Я]+аш[а-яА-Я]+/
str = 'Маша ела кашу, Саша любит Дашуню, это дети наши'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end