#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\d]*(\d{4})"
Local $sString = "Lastname, Firstname. 1900. Title: 1920-1930. etc." & @CRLF & _
"Lastname, Firstname. (1900). Title etc." & @CRLF & _
"1900. Lastname. Firstname" & @CRLF & _
"Lastname, Firstname. 1900"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")