using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\d]*(\d{4})";
string input = @"Lastname, Firstname. 1900. Title: 1920-1930. etc.
Lastname, Firstname. (1900). Title etc.
1900. Lastname. Firstname
Lastname, Firstname. 1900";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}