using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.*filename\*|filename)=(?:([^'""]*)''|(""))([^;]+)\2(?:[;`\n]|$)";
string input = @"Content-Disposition: attachment; filename=""övrigt.xlsx""; filename*=utf-8''%C3%Bvrigt.xlsx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}