re = /(?:.*filename\*|filename)=(?:([^'"]*)''|("))([^;]+)\2(?:[;`\n]|$)/m
str = 'Content-Disposition: attachment; filename="övrigt.xlsx"; filename*=utf-8\'\'%C3%Bvrigt.xlsx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end