package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)post=(\d+)`)
var str = `https://example.com/wp-admin/post.php?post=196475&action=edit&classic-editor`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}