$re = '/(?i)post=(\d+)/u';
$str = 'https://example.com/wp-admin/post.php?post=196475&action=edit&classic-editor';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);