$re = '/<p.*?<\/p>|<em.*?<\/em>/m';
$str = 'привет <p><em>Любой текст, цифры, символы, пробелы</em></p>мир<em>test</em>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;