import Foundation
let pattern = #"<p.*?<\/p>|<em.*?<\/em>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"привет <p><em>Любой текст, цифры, символы, пробелы</em></p>мир<em>test</em>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)