import re
regex = re.compile(r"\/([^\/]+)\/?$")
test_str = ("http://falloutboy.com/111\n"
"http://xn----7sbajjbec0dd3k7b.xn--p1ai/vse_serii_podryad/multiki\n"
"http://www.adobe.com/ru/\n"
"http://www.mamba.ru/en/\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")