package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)M\w{12,15}`)
var str = `MMMMMMMMMMMMMM
M1234567890123
coucou MMMMIMMMMMMMM
coucou MMMMOMMMMMMMM
coucou MMMM10MMMMMMMM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}