// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)M\w{12,15}").unwrap();
let string = "MMMMMMMMMMMMMM
M1234567890123
coucou MMMMIMMMMMMMM
coucou MMMMOMMMMMMMM
coucou MMMM10MMMMMMMM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}